Creating an Animation

Top  Previous  Next

Using the Light-O-Rama SuperStar Sequencer, you can create an animation using a series of stationary images.  Here is an example of how to create an animation:

 

Load some pre-drawn images

Launch the Image dialog box

Select "Apply x,y in Preview (for animations)"

Add the first image

Add the second image

Add the third image

Add the fourth image

What are those boxes under the timeline?

Check your work

How does cut/copy/paste work?

Copy/paste four images

Image group modify

Copy/paste 8 images

Image group modify

Copy/paste 16 images

Image group modify

Copy/paste 13 images

Image group modify

Play the animation

Nudge the animation to the left

Play on "Wide grid" and "Narrow Grid"

Save your animation

Add an eye to Pac Man

Play it again, Sam

 

Load some pre-drawn images

 

Click on the File menu, select "Open...", and open the file "PacManImages.sup", located in the "Samples" directory of your SuperStar Sequences directory.  Be sure to load PacManImages.sup, not PacManAnimation.sup.

 

Launch the Image dialog box

 

Click on the Tools menu and select "Images...".  Click on each image in the image list box to view them.

 

Select "Apply x,y in Preview (for animations)"

 

Select the checkbox labeled "Apply x,y in Preview (for animations)".  This applies the (x,y) coordinate in the preview of the image and it also disables the "End x" and "End y" edit fields (for animation images, the start (x,y) and end (x,y) are the same).

 

Add the first image

 

In the image list box, select "01 Circle".

In the Time Line, select from 1.00 to 1.10 seconds.

In the Image Action x,y Start, type "0" and "44"

In the Image Action name field, type "Mouth shut".

In the Image Action section, click the "Add" button.

 

"1.00 Mouth shut" should appear in the Image Action list box.

 

Remember: If you make a mistake, you can always undo your mistake by clicking on the Edit menu and selecting Undo.

 

Add the second image

 

In the image list box, select "02 Half open".

In the timeline, select from 1.10 to 1.20 seconds.

In the Image Action x,y Start, type "0" and "42".

In the Image Action name field, type "Mouth half open".

In the Image Action section, click the "Add" button.

 

"1.10 Mouth half open" should appear in the Image Action list box.

 

Add the third image

 

In the image list box, select "03 Full open".

In the timeline, select from 1.20 to 1.30 seconds.

In the Image Action x,y Start, type "0" and "40".

In the Image Action name field, type "Mouth full open".

In the Image Action section, click the "Add" button.

 

"1.20 Mouth full open" should appear in the Image Action list box.

 

Add the fourth image

 

In the image list box, select "02 Half open".

In the timeline, select from 1.30 to 1.40 seconds.

In the Image Action x,y Start, type "0" and "38".

In the Image Action name field, type "Mouth half shut".

In the Image Action section, click the "Add" button.

 

"1.30 Mouth half shut" should appear in the Image Action list box.

 

What are those boxes under the timeline?

 

Under the yellow timeline, you should see four light gray boxes.  These boxes are the four image actions you just added.  Click on the first of the four boxes and it wil highlight the first image action, labeled "Mouth shut".  Click on the second and it will highlight the second image action, "Mouth half open".  You can also highlight the image action in the list box, and it will highlight the corresponding box under the timeline.

 

Check your work

 

It is easy to make a mistake while adding the image actions.  Click on the first image action, labeled "Mouth shut", in the image action list box.  Use the down arrow key to step through the image actions.  The y coordinate should step through 44, 42, 40, and 38, and the top of the image should step up two pixels each time.  If the image is not moving, make sure you have "Apply x,y in Preview (for animations)" selected.

 

How does cut/copy/paste work?

 

The fourth, fifth, and sixth buttons on the toolbar are the Cut, Coyp, and Paste buttons.  By default, the objects you paste will be placed in the first open layer, so that effects do not end up on top of each other.  if you wish the pasted objects to stay in their original layers, press the Shift key while clicking on the Paste button.

 

Copy/paste four images

 

Select all four of the light gray boxes under the yellow timeline.

Click on the "Copy" toolbar button.  The selected effects will be copied to the clipboard.

Click on the timeline just after the light gray boxes, which will be at 1.40 seconds.

Click on the Paste toolbar button.  The effects in the clipboard will be pasted starting at 1.40 seconds.

 

Remember, if you make a mistake you can click on the Edit menu and select Undo.

 

Image group modify

 

You should now have eight image actions on the timeline.  Select the last four.

Click on "Group Modify"; the Image Group Modify dialog box should appear.

Select "Modify x,y".

"Add as Offsets to x,y Positions" should already be selected; leave it selected.

Underneath "Start", type "0" into the left field, and type "-8" into the second field.  Click on "OK".  This will subtract 8 from the y coordinate in the selected image actions.

Click on each of the image actions, and you should see your animation move up the screen.

 

Copy/paste 8 images

 

Select all of the eight light gray boxes that you now have under the timeline.  Click on the timeline just after the boxes that are already there.  Click on Copy, and then Click on Paste.

 

Image group modify

 

You should now have 16 image actions on the timeline.  Select the last eight.

Click on "Group Modify"; the Image Group Modify dialog box should appear.

Select "Modify x,y".

"Add as Offsets to x,y Positions" should already be selected; leave it selected.

Underneath "Start", type "0" into the left field, and type "-16" into the second field.  Click on "OK".  This will subtract 16 from the y coordinate in the selected image actions.

Click on each of the image actions, and you should see your animation move up the screen.

 

Copy/paste 16 images

 

Select all of the 16 light gray boxes that you now have under the timeline.  Click on the timeline just after the boxes that are already there.  Click on Copy, and then Click on Paste.

 

Image group modify

 

You should now have 32 image actions on the timeline.  Select the last 16.

Click on "Group Modify"; the Image Group Modify dialog box should appear.

Select "Modify x,y".

"Add as Offsets to x,y Positions" should already be selected; leave it selected.

Underneath "Start", type "0" into the left field, and type "-32" into the second field.  Click on "OK".  This will subtract 32 from the y coordinate in the selected image actions.

Click on each of the image actions, and you should see your animation move up the screen.

 

Copy/paste 13 images

 

Select the first 13 light gray boxes that you now have under the timeline.  Click on the timeline just after the boxes that are already there.  Click on Copy, and then Click on Paste.

 

Image group modify

 

You should now have 45 image actions on the timeline.  Select the last 13.

Click on "Group Modify"; the Image Group Modify dialog box should appear.

Select "Modify x,y".

"Add as Offsets to x,y Positions" should already be selected; leave it selected.

Underneath "Start", type "0" into the left field, and type "-64" into the second field.  Click on "OK".  This will subtract 64 from the y coordinate in the selected image actions.

Click on each of the image actions, and you should see your animation move up the screen.

 

Your animation is now complete.

 

Play the animation

 

Click on the Play button.  You should see Pac Man chase the red ghost up the ribbons.

 

Nudge the animation to the left

 

The chomping sound starts before you see the animation start.  To synchronize the appearance of the animation with the start of the chomping sound, select all of the image actions under the timeline.  Click on the "Nudge Left" toolbar button (the button with an hourglass and a left arrow on it).  All the image actions should move left by 0.05 seconds.  Nudge left three or four more times and the animation should be more in sync with the sound.

 

Play on "Wide Grid" and "Narrow Grid"

 

Click on the "Wide Grid" toolbar buton and play the animation.

 

Click on the "Narrow Grid" toolbar button and play the animation.

 

Save your animation

 

Click on the file menu, and select "Save As...".  Save the file as "MyPacManAnimation.sup".

 

Note: There is already a file named PacManAnimation.sup in the Samples directory.  You can compare your animation with this animation.

 

Well, it was a bit tedious, but it was worth the effort: You now have a cool Pac Man animation!

 

Add an eye to Pac Man

 

Even after the image actions are all defined, you can still modify the images that they use.  For example, you could add an eye to the yellow Pac Man.  Note that to change the images, you will be working in the upper Image section of the image dialog.  Do not click on anything in the lower Image Action section.

 

Select "01 Circle" in the Image list box.

Use the right mouse button to erase some pixels on the yellow Pac Man to make an eye.

Click on the Image "Modify" button in the upper Image section (not the lower Image Action "Modify" button).

Repeat the same process for "02 Half open" from the Image list box.

Repeat the same process for "03 Full open" from the Image list box.

 

Play it again, Sam

 

Play the animation again, and you will see the eye in the entire animation.