What's New in Version 1.x.x

Top  Previous  Next

What's New in Version 1.5.0

What's New in Version 1.4.0

 

 

What's New in Version 1.5.0

 

The following new features, changes, and fixes have been made for Light-O-Rama version 1.5.0:

 

Tapper Wizard Behavior Change

Channel Deletion Fix

Channel Button Feedback during Loops Fixed

Animator Fix

 

Tapper Wizard Behavior Change

 

When the Tapper Wizard's "toggle" and "snap to existing events" options are used together, both the beginning time and the end time of each toggle are snapped to existing events.  This causes the combination to behave in a way that is probably more similar to what most people would expect.

 

Channel Deletion Fix

 

Various problems occurred when the last channel in a sequence was deleted.  These have been fixed.

 

Channel Button Feedback during Loops Fixed

 

When the Sequence Editor was used to play a sequence with a loop, and the end of the loop was reached, just before going back to the beginning of the loop, the channel buttons' color displays would sometimes briefly act upon the event just after the loop.  This has been fixed.  Note that it did not affect the actual display of lights; it only affected the display within the Sequence Editor itself.

 

Animator Fix

 

If the Animator was sized so that scroll bars were necessary, the "draw" and "erase" functions would act upon the wrong cells.  This has been fixed.

 

What's New in Version 1.4.0

 

Time Scale

Copy and Paste Timings

Animation Saved in Channel Configuration Export

Right-Click in Animator Now Erases

Duration in Status Bar

Play Again

Several Zoom Improvements

Delete Selected Events

Animator Efficiency

Manual Stop Stays in Position

Program's Main Window Remembers Its Position

Bug Fixes and Internal Improvements

 

Time Scale

 

In the Sequence Editor, at the top of each sequence, a time scale is optionally displayed.  Also, during play, the button to the left of this scale now displays the current time offset.

 

Whether the time scale is displayed or not for any particular sequence can be controlled via the View menu, or via a button on the toolbar.  It can be turned on or off by default using the Display Preferences dialog on the Edit menu.

 

Copy and Paste Timings

 

In the Sequence Editor, you can now copy and paste timings - that is, make new cells having the same duration and relative positions as some existing timings.

 

To copy a set of timings, select the range of cells that you want to copy, and then copy them in one of three ways:

 

Select "Copy Timing" from the Edit menu;

Select "Copy Timing" from the right-click context menu;

Using the keyboard, hold the "Shift" key and simultaneously hit the "Delete" (or "Del") key.

 

Once these timings are copied, you can paste them in one of several ways:

 

Via the right-click context menu:

"Paste timing at (the centisecond that was right-clicked)";

"Paste timing at ...", which brings up a dialog box asking the centisecond to paste to (defaulting to the centisecond that was right-clicked");

"Paste timing multiple", which is similar, but also asks how many times you would like to paste the timings consecutively, or if you wish to keep pasting them all the way to the end of the file.

Via the Edit menu, using "Paste Timing".  This is the same as the right-click menu's "Paste timing multiple", except that the starting centisecond defaults to the start of the current selection, rather than the right-clicked centisecond.

Using the keyboard, hold the "Shift" key and simultaneously hit the "Insert" (or "Ins") key.  This is the same as "Paste Timing" from the Edit menu.

 

Animation Saved in Channel Configuration Export

 

When a sequence's channel configuration is saved (using "Export Channel Configuration" from the Edit menu of the Sequence Editor), the sequence's animation is saved along with it.  When the channel configuration is later imported into another sequence (using "Import Channel Configuration" from the same menu), the user is given the option to import the animation as well.

 

Right-Click in Animator Now Erases

 

The right mouse button can now be used to erase cells in the Animator.

 

Duration in Status Bar

 

The status bar along the bottom of the Sequence Editor now shows not only the total time and selected time range, but also the duration of the selected time range.

 

Play Again

 

You can now tell the Sequence Editor to "play again".  This causes it to play the last thing that you asked it to play, regardless of the current play settings.  For example, if you choose a certain time range, with the play range set to "Selection", the Sequence Editor will play that selection.  After play ends, you may fix some problem that you noticed, which causes the selected time range to change.  If you wanted to play the same time range again, previously, you would have to re-select that time range.  Now, you can instead simply hit "Play Again".

 

There are two ways to do this: Via the "Play Again" item of the Play menu, and via a new toolbar button.

 

Several Zoom Improvements

 

Several zoom improvements have been made in the Sequence Editor:

 

The "Zoom In" and "Zoom Out" buttons on the toolbar have been replaced by individual buttons for "Zoom Channels In", "Zoom Channels Out", "Zoom Time In", and "Zoom Time Out".

Preferred zoom settings can now be saved or restored via the Zoom Preferences dialog on the Edit menu.  The saved zoom preferences are used by default when opening or creating new sequences.

Keyboard shortcuts now exist to zoom in various directions: Alt-Up and Alt-Down to zoom channels in and out, and Alt-Left and Alt-Right to zoom time in and out.  Also, Alt-Page-Up and Alt-Page-Down to go to the minimum or maximum channel zoom settings, and Alt-Home and Alt-End for the minimum and maximum time zoom settings.

 

Delete Selected Timings

 

In the Sequence Editor, several timings can now be deleted at once, by selecting a range of timings and choosing "Delete Selected Timings" from the right-click context menu.

 

Animator Efficiency

 

The Animator has been made more efficient, using less CPU during play.  This improves the jerkiness that was seen on some machines during play while the Animator window was open.

 

Manual Stop Stays in Position

 

When you manually stop play of a sequence (as opposed to letting it stop by reaching its natural end), the Sequence Editor now continues to display the screen that was being displayed when play was stopped.

 

Program's Main Window Remembers Its Position

 

When you start the Sequence Editor, its main window is now opened in the same position that it was in the last time it was closed.

 

Bug Fixes, Internal Improvements

 

Several bug fixes and internal improvements have been made.