Visualization Sequences

Top  Previous  Next

The Light-O-Rama SuperStar Sequencer can import visualizations created using the Light-O-Rama Visualizer.

 

Import Visualization

Special notes on Import Visualization

Import Visualization Pair

Create Wrapped Tree Visualization

VisEffects

Instant Sequences using a visualization

Instant Sequences using a quick visualization

Is the SuperStar program now a Visualizer program?

Selecting a light fixture

Adding an effect

Play the effect

Add a morph

Play it

The concept

Instant Sequence

Visualizer Keywords/SuperStar Settings in Visualizer Props and Fixtures

Visualizer Prop Parameters

Visualizer Fixture Parameters

Future enhancements

 

Import Visualization

 

To use this feature, click on the SuperStar Sequencer's File menu and select "Import Visualization...".  The Import Visualization dialog box will appear:

 

Scrunch the Sequencing Grid: "Scrunch the Sequencing Grid" and it will scrunch everything into as few rows as possible.  Using "Scrunch the Sequencing Grid" makes it so if you have 100 light fixtures or less, you will be able to fit all of them onto two sequencing rows.  Note: Instant Sequence will work best if you do not "Scrunch the Sequencing Grid".
 

Sorted by Rows: This setting will produce the best Instant Sequences, and is the recommended setting for importing a visualization.  Your lights will be sorted by rows, and each light fixture will be represented by a box on the green sequencing rows.  The program does its best to sort your lights along the rows that it sees.  Many light displays have two or three rows of lights; for instance, there could be lights at the roof line, the window line, and the ground line.  In that case, the program will create three rows of green sequencing squares above your visualization.  The first row will contain the light fixtures that the program found at the roof line, the next row will contain the light fixtures that the program found at the window line, and the third row will contain the light fixtures the program found at the ground line.  Note that this is just an example; the program may find a different number of rows in your visualization.
 
A sequencing row can only have 50 boxes, so if you have more than 50 light fixtures in a row on your visualization, then the light fixtures will be split into more than one sequencing row.  If you have a prop with many light fixtures in it, the program does its best to not split the prop between lines.  Props are assigned to a row as a group.  The center of the prop is used to decide which row the prop will be placed in.
 
Important note: The fixtures in a prop will be placed onto the row in the same order that they were added in the Visualizer.  To change the order of the fixtures, do the following:
 
1. Launch the Visualizer program.
2. Bring up the Properties dialog box for that prop.
3. In the "General" tab, click on the "Change Order of Fixtures" button at the bottom.
4. Save the visualization file.
5. Import the visualization file into SuperStar.
6. Click on the fixtures in the prop, and you should see that they are ordered differently in the green sequencing row.
 
CCRs are always placed first.  The sorting applies only to props and light fixtures.
 
In short, the program sorts things in a way that makes it easiest to sequence, and will produce the best instant sequences.
 

Sequencing Grid:
 
Max Length: This sets the maximum length of a sequencing row.  The max length can be set from 25 to 200.  The default is 50, and this works best for most visualizations.  If you have a row of lights in your visualization that will not fit into one sequencing row, then you can increase the length of a row so that the row of lights will all fit into one sequencing row.  Do not make this value any larger than necessary, because it can make the size of the squares in the sequencing grid small and harder to click on.
 
Horizontal: Most light displays are wider than they are tall.  For most displays, it is suggested that you use a horizontal display.  This will place a horizontal sequencing grid above your visualization, and leaves the most room for your visualization.
 
Vertical: Vertical orientation is designed for displays that are taller than they are wide.  For example, if you are sequencing a visualization of an RGB megatree then you would want vertical orientation.  A vertical orientation will place a vertical sequencing grid to the right of your visualization.
 
Normal: Normal mode creates one green sequencing square for each fixture or CCR pixel on your visualization.
 
Wrap Around: Wrap Around mode creates a duplicate set of sequencing squares to the right of the normal set of sequencing squares so that you end up with two green sequencing squares for each fixture or CCR pixel on your visualization.  This mode is designed for use with 360 degree trees.  It allows easier creation of effects so you can start them at any point on the tree and wrap around to any other point on the tree.  For example, you can start a morph in the middle of the tree and end it on the middle of the wrap around part of the sequencing grid.  The resulting morph will start in the middle of the tree, cross the last string onto the first string, and end in the middle of the tree.

 

Maximum Detection Lines (green lines on the visualization): This setting defaults to 4, and with a setting of 4 means that your lights will be assigned to four rows or less.  The detection lines are drawn in green across the visualization.  A setting of 4 works well for most displays.  however, if your display is large or just has a lot of different rows, then try increasing the number.  For example, if you have a row of mini-trees, you would want them all in the same sequencing row and to be consecutive in the row.  If other fixtures are being placed in between some of the mini-trees, then you could increase the Maximum Detection Lines setting to 5 or 6 or higher until all the mini-trees get put consecutively into their own rows.
 
In some cases, you will need to move the fixtures and props a bit in your visualization to isolate them into their own areas so that they get placed into rows in the desired manner.

 

Special notes on Import Visualization

 

The SuperStar Sequencer allows fixtures with identical channel assignments.  For example, you may have a snowman fixture and a bell fixture that are both plugged into the same channel, so that they have the same channel assignment.  In this example, the snowman and the bell will be treated as if they were one fixture, and will be assigned to the same square on the sequencing grid.

 

When importing your visualization, you may get the following warnings:

 

"Warning: Found one or more fixtures with unassigned channels.  Fixture [Bush 01] has no channels assigned.  This and any other fixtures with no channels assigned will be dark gray and will be inactive." This warning means that the fixture mentioned (in this example, "Bush 01") has no channels assigned to it.  A fixture with no channels assigned cannot be exported because the program has no channel information for that fixture.  Therefore, the fixture is drawn in dark gray and cannot be selected, nor can any effects be assigned to it.  Note that the fixture mentioned in the warning is the first fixture found with no channels assigned; there could also be other fixtures with no channels assigned.  Also realize that you can still sequence all the other fixtures and export the sequence, and all other fixtures will work.
 

"Warning: Found some fixtures that share a channel yet don't share all channels.  Channel [White] in Fixture [Mega Tree bundle 01] and Channel [Red] in Fixture [Mega Tree bundle 04] are both assigned to 0A.02.  This usually happens when a wrong channel is entered by mistake.  Please use the Visualizer program to check the two fixtures mentioned to see if a channel was entered by mistake.  The SuperStar Sequencer allows fixtures that have identical channels but does not allow fixtures where some channels are the same and some are not.  When this happens, the first occurrence of a channel will be active, the duplicate occurrences of a channel thereafter will be inactive." This very long warning attempts to explain that the program allows fixtures to have identical channel assignments, but if two fixtures share some channels but have some channels that are different, it is difficult for the program to decide how you would want those fixtures assigned to the sequencing grid, and so it disables the duplicate channel assignments.  As mentioned in the warning, this may have happened because you entered incorrect channel information by mistake.  However, if you intentionally assigned the channels in this manner, the program doesn't know how to handle it.  You are encouraged to use a different channel assignment scheme, but if you can't, it just means that manual sequencing for those fixtures could be difficult.  You can still use Instant Sequence, and the sequence should look OK, and will export and play fine.
 

"Warning: A Cosmic Color Device such as a CCR, CCB, or CCP shares a channel with another fixture.  Fixture [CCR 02] and Fixture [Bush 03] both use channel 02.03.  This usually happens when a wrong channel is entered by mistake.  Please use the Visualizer program to check the two fixtures mentioned to see if a channel was entered by mistake.  The SuperStar Sequencer does not allow a Cosmic Color Device to share channels with other fixtures.  Fixture [Bush 03] will be dark gray and will be inactive." This warning is self-explanatory.  Using the same channel assignment for a fixture that is in a CCR is invalid.  The fixture will be drawn in dark gray, and you will not be able to select it.  As with the other warnings, realize that all other fixtures will sequence and export just fine.

 

Import Visualization Pair

 

To use this feature, click on the "File" menu and select "Import Visualization Pair...".  Use the "Choose Row Visualization..." button and the "Choose Real Visualization..." button to choose the visualization files you want to import.  Then use the "Import Visualization Pair" button to import both of the files.

 

Purpose of having two visualizations: Import Visualization Pair allows the import of a "Row Visualization" and a "Real Visualization".  If you already have a visualization of your light display, you probably laid the lights out to appear as they do in your actual display.  Use this visualization as your "Real Visualization".  You can move the fixtures and props around to organize them in rows and then save that visualization with a different name, and that becomes your "Row Visualization".  SuperStar will create the sequencing grid based upon how you have organized your "Row Visualization".  While entering normal effects, the "Row Visualization" will be displayed on the SuperStar screen.  During the playback of the sequence, the "Real Visualization" will be used.  When entering visEffects, the "Real Visualization" will be displayed.

 

Example of using two visualizations: This is a powerful feature that allows you to design how your lights are mapped to the sequencing grid.  For example, in your "Real Visualization", you might have some candy cane props where each candy cane has 12 channels, and you have four candy canes in a row.  By default, SuperStar looks for rows of lights, and it will fit as many lights as it can in each row on the sequencing grid.  But in this case, it is desirable to have each candy cane on its own row, so that you have four rows, each row with 12 squares for the 12 channels in each candy cane.  Then it is easy to create effects that go up and down all the candy canes, as well as effects that travel across the candy canes.  So, to accomplish this, you can move each of the four candy canes to their own row on the "Row Visualization", and still use the "Real Visualization" for playback and for entry of visEffects.

 

In the samples folder, there is a file named CandyCanes_sample.sup".  Open and play this file, and you will see how it uses two visualizations to arrange the candy canes in a way that makes them easy to sequence.

 

Create Wrapped Tree Visualization
 

Use this feature to create a visualization of Cosmic Color Pixels or Cosmic Color Bulbs wrapped around a tree. This is different than creating a mega-tree. Traditional mega-trees have vertical strings of lights. A wrapped tree has one long string of lights wrapped around the tree. This gives a more traditional look to the tree and also makes it so the concentration of lights is the same in all areas of the tree.

 

To created a wrapped tree visualization, click on the Tools menu and select “Create Wrapped Tree Visualization”:

 

Units: select inches or centimeters
 

Nbr of Trees: Enter the number of wrapped trees you want to do. For example, you might have 8 mini-trees that you want to wrap with Cosmic Color Pixels.
 

Blank Grid Lines Between Trees: If you have more than one tree you may want some blank columns on the sequencing grid between each tree. For example, if you have several mini-trees and you do a shock-wave effect on one, the effect may “bleed “ over to the trees next to it if there are no black lines in the sequencing grid.
 

Top Diameter: This is the top diameter of the tree. It defaults to 0 but you can set it to any value from 0 up to the value set as the Bottom diameter.
 

Bottom Diameter: This is the bottom diameter of the tree.  This value must be 10 or greater. The upper limit of the value depends on the number of pixels you have and the spacing between the pixels.  The diameter is measured starting from one point at the bottom of the tree and getting to the other side of the tree going through the trunk.
 

Top Circumference: This field is linked to the Top Diameter field. Setting the diameter will also change the value in the circumference field. Setting the value in the circumference will also set the value in the diameter field.
 

Bottom Circumference: This field is linked to the Bottom Diameter field. Setting the diameter will also change the value in the circumference field. Setting the value in the circumference will also set the value in the diameter field.  The circumference is measured from a point at the bottom of the tree and going around the tree to arrive back at the same place you started.
 

Slant Height: This is the slant height of the tree. Note that this is not the vertical height of the tree. In other words, it is the height of the tree measured from the outside edge of the base of the tree up to the top of where the lights stop on the tree. Note the top of the tree may be different from where the lights end at the top of the tree.  You want to measure from where lights start to where the lights stop.
 

Pixel Spacing: This is the space between the pixels on you string(s). For Cosmic Color Pixels this is 6 inches. But it is best to stretch out your string of lights and measure the length of the string to get the actually average spacing of your lights. For example, a string of Cosmic Color Pixels has 50 lights. Lay the string on the floor and  pull on the end of the lights to give enough tension on the light string to equal the amount of tension you expect to be on the string as you wrap the tree. Then measure from the first pixel to the last pixel and then divide by 49. Note that you do not divide by 50, you divide by one less than the number of pixels because that is the number of spaces in what you are measuring.  The idea is that the same spacing you are measuring on the floor is the same spacing you will have on the tree.
 

Nbr of Pixels: This is the number of pixels in all of the strings of lights you are going to wrap around each tree. For example, if you have 4 strings of Cosmic Color Pixels, there are 50 pixels in each string so you have a total of 200 pixels. This means that you will be connecting the strings end-to-end and will treat them as one long 200 pixel string. One way to “connect them end-to-end” is to overlap the wires of the strings and use 2 zip ties to wrap around the overlapping wires. Adjust the overlap of the wires so that the spacing from the last light of the string to the first light of the next string is equal to the spacing of your pixels on the rest of the string.
 

Pixel Size: This sets the size of the pixels in the visualization.
 

Create Wrapping Guide and Visualization: This creates the wrapping guide and the visualization of the wrapped tree. Click on the combo box above this button to see the wrapping guide values. The “Vert Marks” are the distance from the bottom of the tree to the start of each wrap. The “Wrap Marks” are the Pixel Count at the start of each wrap. For example, if the Vert Mark for wrap 3 is 10.75 then it means wrap 3 starts at 10.75 inches from the bottom of the tree. And if the “Wrap Mark” is 64.32 it means that wrap 3 starts at 64.32 pixels from the start of the string of pixels.
 
What you want to do is mark all the “Wrap marks” on your string of lights before you start wrapping. The first pixel starts at the bottom of the tree and marks the 0 pixel, then you count the pixels from there. So the first pixel is the 0 pixel, and the second pixel is the 1 pixel and the third pixel is the 2 pixel and so on.  That means “wrap mark” 0.50 would be half way between the first and second pixel. 1.50 would half way between the 2nd and 3rd pixels. So to find pixel 64.32 you would start at the beginning of the string and skip the first pixel and start counting at the second pixel until your count gets to 64 and then mark a point that is about .32 beyond 64.
 
Note that a new wrapping guide and visualization only gets created if you click on the “Create Wrapping Guide and Visualization” button.

 

 

VisEffects

 

The standard effects are placed on the green sequencing grid, and get played to the visualization.  The visEffects are placed directly on the visualization, and also get played to the visualization.  The difference is that visEffects use the position of the lights in the visualization instead of the position of the lights on the sequencing grid.  You must have an imported visualization on the SuperStar screen in order to do visEffects.

 

Currently, visEffects are only supported by morphs.  Click on the Tools menu, and select "Morphs..." to bring up the "Morph Setup" dialog box.  at the bottom of the dialog box, click on the "VisEffect" box.  The visualization will become smaller, and you will see the "1a-1b" and "2a-2b" morph lines.  Click on the Add button in the "Morph Setup" dialog box and play it.  You will see the morph smoothly applied to all the lights in the visualization.

 

In the samples folder, there is a file named "CandyCanes_sample.sup".  Open and play this file, and you will first see some standard effects played to the candy canes.  At the end, you will see some visEffects.

 

Instant Sequences using a visualization

 

The Instant Sequence also feature works for visualizations, using the following steps:

 

Click on the File menu and select "Import Visualization"

Select a visualization file that you created using the Light-O-Rama Visualizer

Press Ctrl+I to launch the Instant Sequence dialog box, and use the three buttons in the lower left of the dialog box

Click on the "Open Audio File" button to open your audio file

Click on the "Sequence All" button

Click on the "Play/Stop All" button

 

Instant Sequences using a quick visualization

 

Want to use Instant Sequence but don't have a visualization of your lights? The SuperStar Sequencer can create a quick visualization file for you:

 

Click on the Tools menu and select "Create Quick Visualization".

Place a checkmark by each controller that you have.  If necessary, change the settings for each controller.  For example, if you have four 16 channel controllers and they have unit IDs 01, 02, 03, and 04, simply place a checkmark by the first four controllers listed in the dialog box.

Click on "Create QuickVis", and it will create a visualization file named "QuickVis.lee".  The visualization will be a grid of lights where each light represents a channel.  With this grid of lights, you can now use Instant Sequence to create a sequence for your lights.

After creating the sequence, click on the File menu and select "Export", and you will then be able to play the sequence to your lights using the Light-O-Rama Sequence Editor.

 

Is the SuperStar program now a Visualizer program?

 

No.  The SuperStar Sequencer imports the visualization file and displays it in the SuperStar work area.  The SuperStar Sequencer can only display the visualization file; the Light-O-Rama Visualizer is used to create or modify visualizations.

 

Selecting a light fixture

 

After importing a visualization file, you can click on any of the light string fixtures to select them.  A single click selects one item, while Ctrl+click can be used to select additional items.  A click and drag will select any item within the drag rectangle.  Each light string fixture is also mapped to a box in the green sequencing grid.  When clicking on a light fixture, you will see it become selected, and will also see a green square get selected.  You can also select fixtures by clicking on the green squares.  Left click selects, and right click deselects.

 

Adding an effect

 

Select one or more light fixtures.

Click on the Tools menu and select Scenes.  The Scene dialog box will appear.

Click on the Add button in the Scene dialog box.  A white bar will appear in the time layer area.  This bar represents the effect you just added.

 

Play the effect

 

In the toolbar is a group of buttons that look like the controls on a tape recorder.  Press the Play button (the button with a right-facing triangle); this will play eight seconds of the sequence.  After pressing Play, you should see your selected light fixtures turn on when the play cursor runs across the white bar which represents the effect that you just added.

 

Add a morph

 

Click on the Tools menu and select Morphs.  The Morph dialog box appears, and the first and last boxes in the green sequencing grid should have "1" and "2" on them.

In the yellow time scale, select from 3.00 seconds to 4.00 seconds.

Click on the Add button in the Morph dialog box.

 

A white bar with a tail should appear in the time layer area.

 

Play it

 

Click on the Play button again.  When the play cursor runs across the white bar with a tail, the morph will turn on every fixture, one at a time.  In other words, the effect starts at the "1" on the green sequencing grid, and travels to the "2" on the green sequencing grid.  This ends up doing a sweep or a chase across all the fixtures.

 

The concept

 

Every light in your visualization has a location and a color.  When selecting a fixture, you have selected a location.  You select the color by using the red, green, blue and white color controls on the left side of the SuperStar Sequencer.  The default is to have all four color controls "on".  However, if you want to turn on all the red lights in your display, turn on only the red color controls and select all your fixtures.  Add a scene, and you will see only the red lights in your display turn on when you hit the Play button.

 

Note: Click on the word "Main" above the color controls, and it will cycle through the basic rainbow colors.

 

Instant Sequence

 

You can use the Instant Sequence feature on your visualization:

 

Click on the Tools menu and select "Instant Sequence".

If you don't already have an audio file loaded, click on the "Open Audio File" button in the Instant Sequence dialog box.

Click on the "Sequence All" button.

After all the processing is done, click on the "Play/Stop All" button.

 

If you want to change the number of effects that are being created, click on the Timing Map button in the upper left of the Timing Map dialog box, and change the Sensitivity setting.

 

To create a different instant sequence, click on the "Roll Dice" button in the Instant Sequence dialog box.  Then click on Sequence All, then Play/Stop All.

 

Visualizer Keywords/SuperStar Settings in Visualizer Props and Fixtures

 

When you import a Visualization, SuperStar does its best to map the lights to the sequencing grid in a sensible way.  But there are cases where you may want to change how the lights are mapped to the sequencing grid.  In older versions of SuperStar, you used keywords that you placed in the comment area of a Prop or Fixture in a visualization.  The keywords are still supported for backward compatibility, but the preferred way to apply these settings is now through the use of settings that are visible by pressing the “superstar” button that is in the Visualizer Prop dialog box and the Visualizer Fixture dialog box. By clicking on the “superstar” button you will be able to set all the same settings that were done by the keywords.

 

The following describes the old use the keywords. It is documented for backward compatibility. Instead of using the keywords, you should now use the “superstar” settings that are in the Prop dialog box and the Fixture dialog box in the Visualizer. Note that if you use keywords and Visualizer superstar settings, the keywords will take priority.

 

The word "superstar" in the comment area tells SuperStar that you have placed a keyword in the comment.  After the word "superstar" you can place one or more of the keywords listed below.  For example, if you wanted to mark your prop as a matrix, you would enter "superstar matrix" in the comment area of the Prop Properties box in the Visualizer.

 

Parameters that can be used with props

 

SuperStarPropParams
SuperStar Properties for Props, found in the Visualizer program

 

Reverse Order in Superstar - Superstar attempts to layout the fixtures in your prop in a logical order, but if it didn't do it in the order you want, then use this check-box to reverse the order of the fixtures in the prop.  Note that reversing the order of the props using the Prop Properties dialog box will not change the order that SuperStar will use.
 

Force Superstar Row/Column - Use this check-box along with the following 'Row' and 'Column' fields to change the row and column of the prop on the sequencing grid.  Note that the row and column notation was created for a vertical import; if you use a horizontal import, then row and column will seem reversed.  To see an example of the use of row and column, look at the 24x25Tree_4RowGlob.lee visualization file from the Samples folder.  You can open this file in the Visualizer to see how the keywords are used in the comment area of the props.  You can also import this file into Superstar to see how the props have been moved down in the sequencing grid.
 

Use My Order rather than Superstar's - This tells Superstar to disregard what row the fixtures are in, and instead add the fixtures in the same order as they have been added to the prop.  Note that in the Prop Properties dialog box in the Visualizer, there is a "Change Order" button that allows you to change the order of fixtures in a prop.  You can change the order there, and SuperStar will change the order in the sequencing grid as well.  Also, if the prop contains CCRs, then the this check-box also tells SuperStar to add the pixels of the CCR in the same order as in the visualization.
 

This Prop is a Star/Topper - This marks the prop as a star of a Superstar display.  Use this to make sure that the star commands of a SuperStar sequence get mapped to the star in your visualization.
 

This Prop is a Matrix - This marks the prop as a matrix of pixels. Superstar will automatically detect most matrix layouts.  But if, for example, you have some CCRs or DMX Pixels arranged in a fan shape, you probably want the pixels arranged as a matrix in the sequencing rows, but SuperStar will not recognize the fan shape as a shape that should be a matrix.  So, you can mark the fan prop as a matrix using this keyword.
 

Parameters that can be used with fixtures

 

SuperStarFixtureParams

SuperStar Properties for Props
 

Reverse Order in Superstar - SuperStar attempts to lay out the pixels in a CCR or DMX Pixel fixture in a logical order, but if it didn't do it in the order you want, then use this check-box to reverse the order of the pixels in the fixture.
 

Force Superstar Row/Column - Use this check-box along with the following 'Row' and 'Column' fields to change the row and column of thefixture on the sequencing grid.  Note that the row and column notation was created for a vertical import; if you use a horizontal import, then row and column will seem reversed.
 

Locations - Use this area to add a list of row and column locations for each light in the fixture.  The row and column should be separated by a comma, and then there should be a space between each row, column pair.  For example, "1,2 1,3" would mean place the first light in the fixture at row 1, column 2, and place the second light in the fixture at row 1, column 3.  To see an example, look at the 24x25Tree_4RowGlobe.lee visualization file from the Samples folder.  You can open this file in the Visualizer to see how the location of pixels is specified for the globe fixture.  You can also import this file into SuperStar to see how the lights in the globe fixtures have been moved down in the sequencing grid.
 

Color Temperature - These check-boxes are used for fixtures containing RGB lights, marking such fixtures as having "cool white" LEDs or "warm white" LEDs. SuperStar uses these keywords to determine how to best balance the colors in RGB lights.

 

Future enhancements

 

While a wide range of visualizations have been tested with the SuperStar Sequencer, there is an even wider range of possible visualizations, and so it is difficult to test every scenario.  So, as you work with your particular visualization, feedback is welcomed on ways that support can be improved for your particular needs.  Please send such feedback to wishlist@lightorama.com.