Overview

Top  Previous  Next

This page gives an overview of the Light-O-Rama SuperStar Sequencer:

 

A new approach

Exporting a sequence

Exporting in the new intensity data format

Playing a sequence exported as intensity data

Exporting in the legacy format

Merge Intensity Data Files

Playing a sequence exported in legacy format (play as a standalone sequence)

Playing a sequence exported in legacy format as a subsequence

Floating windows

Placing a sequence exported in legacy format into your main sequence using "Copy/Paste"

Things to note

The Demo version

Default layout

PowerPoint presentations

 

A New Approach

 

The SuperStar Sequencer is a new approach to light sequencing.  Think of the SuperStar Sequencer as a "front end" to the Light-O-Rama Sequence Editor.  A series of effects are created and can be played to the computer screen, but to play the sequence to your Cosmic Color Ribbons or other lights, you export the SuperStar sequence to a file that the Sequence Editor can play.

 

If the exported file is from a Visualization Sequence and the SuperStar sequence contains all you lights, then you can play the file as a standalone sequence, simply by opening the exported file in the Light-O-Rama Sequence Editor and playing it.

 

If the exported file only contans the CCRs of the sequence, then the exported file can be played in one of three ways:

 

As a standalone sequence (just load the file into the Sequence Editor and play it).

As a subsequence in your main sequence.

Place the sequence into your main sequence using copy and paste in the Sequence Editor.

 

Exporting a Sequence

 

To export a sequence, click on the File menu and select "Export to Sequence Editor".  The "Export to Sequence Editor" dialog box will appear.

 

"Export in Legacy Format": Legacy format is the format that was always used prior to the S4 release.  Use this option to export in the same way that was always used prior to the release of S4.

"Export in New Format (as Intensity Data)": This option will export in the new format as intensity data.  All of the exported data will appear as one line at the bottom of the sequence in the Sequence Editor.  The new intensity data format is designed to better support large numbers of channels and pixels. The intensity data format is also very handy because it automatically gets merged in with your main sequence and will play alongside your main sequence.  Please note that you must have a Pro level license in order to use intensity data.

"Add Intensity Data to Existing Sequence": Choose this option if you already have a main sequence and you want to add the exported data to the existing main sequence.

"Add Intensity Data to New Sequence": Choose this option if you want to add the intensity data to a new sequence. SuperStar will create a new Sequence Editor sequence with a main body that is empty and will add the intensity data to it.  You can then play the sequence.  This is a way to play the exported sequence as a "stand alone"sequence.

 

Exporting in the New Intensity Data Format

 

Intensity data gets placed on a line at the bottom of a Sequence Editor sequence. The intensity data is played alongside the rest of the sequence so it automatically gets merged with the rest of the sequence. Note that the intensity data should not send commands to any of the same channels that are in the main sequence.

 

Playing a Sequence Exported as Intensity Data

 

Launch the Light-O-Rama Sequence Editor.  Click on the "Existing Sequence" tab.  Select the file you exported, and click on the "OK" button.  Click on the Play button.

 

Exporting in the Legacy Format

 

If the name of your SuperStar sequence was “MyAwesomeSequence.sup” then the default name for the exported sequence will be “MyAwesomeSequence_sup.lms.” You can change the name if you wish.

 

When use the legacy format you can play it as a stand-alone sequence.  This is relatively simple to do and is described below.

 

To combine a legacy format sequence with a main sequence you can use the subsequence method, or the copy/paste method. These two methods are described below:

 

Merge Intensity Data Files

 

The Sequence Editor will only play one SuperStar intensity data file for any given sequence.  In a large light display, you may have more than one mega tree or matrix, and you might sequence each of them separately.  To be able to use intensity data for all of them, you can merge the intensity data files together:

 

First, export each piece of your display as an intensity data file by doing the following:

 

First, export the individual pieces:

 

Click on the File menu and select "Export to Sequence Editor"

Select "Export in New Format (as Intensity Data)"

Select "Add Intensity Data to New Sequence"

Click on "OK", and type in a file name and export to that file name.

Do this with each piece of your display that you sequence separately.

 

Next, merge them together:

 

Click on the File menu and select "Merge Intensity Data Files"

Click on the "Select Intensity Data Files to Merge" button

In the dialog box that appears, select two or more files (using Ctrl + left mouse click)

Select "Add Merged Intensity Data to Existing Sequence" or "Add Merged Data to New Sequence"

Click on OK.

 

Finally, launch the Sequence Editor and open the sequence with the merged intensity data.  You should see a light blue colored line at the bottom of the sequence that says "Pixel Editor and SuperStar Props", and below that you should see a row labeled "SS Props".  The "SS Props" line is the merged intensity data.

 

Playing a Sequence Exported in Legacy Format (Play as a Stand-alone Sequence)

 

Launch the Light-O-Rama Sequence Editor.  In the New and Open dialog, click on the "Existing Sequence" tab.  Select the file that you exported from the SuperStar Sequencer (in the example given above, the exported file name was "MyAwesomeSequence.sup.lms").  Click on the "OK" button, and then click on the Sequence Editor's "Play" button.

 

Playing a Sequence Exported in Legacy Format as a Subsequence

 

To use an exported SuperStar sequence as a subsequence, launch the Light-O-Rama Sequence Editor.  Open your sequence that you want to put the exported sequence into as a subsequence.  Insert a new channel into the sequence, and click on that channel's button to open up its Channel Settings dialog.

 

Change the channel's device type to "Sequence", and then click on the "..." button (near the bottom, on the "Sequence" line) to select the file that you exported from SuperStar (in the example above, "MyAwesomeSequence.sup.lms").  Also change the channel's name and color if you wish.

 

The subsequence will be played only while the grid boxes for this channel are on, so use the Sequence Editor's On tool to turn them on for the time range (or ranges) that you want.  For example, to play the subsequence throughout the entire sequence, select the entire row, and apply the On tool to it.

 

The main sequence and the subsequence should not both try to control the same lights; it is recommended that any circuits referred to in the subsequence are removed from and kept out of the main sequence.  Doing otherwise may cause unpredictable results.

 

Floating Windows

 

When using a large number of CCRs, or when importing a visualization of a large display, the sequencing grid and/or the visualization in SuperStar can become small.  You can put the sequencing grid and the visualization each in their own window.  That way you can place them where you want, and size them how you want.  And if you have two monitors, you can put one of them in each monitor.

 

To activate floating windows, click on the "View" menu and select "Floating Windows".

 

Placing a Sequence Exported in Legacy Format into Your Main Sequence Using "Copy/Paste"

 

To place an exported SuperStar sequence into a main sequence using copy and paste, launch the Sequence Editor and open the sequence that you exported from SuperStar, and select all channels in it, from the beginning to the end.  Copy them.

 

Next, make sure that your Clipboard's paste mode setting is set to Paste by Time.

 

Then open your main sequence.  Define the CCR channels in it (for example, using the "Cosmic Color Device" option of the Insert Device dialog - use a resolution of 50 pixels, native mode for the unit IDs, and triples for the channel mode).  Define one such CCR in the sequence for every CCR that you have in SuperStar.  Select the first cell in the first row of the CCR channels that you added, and paste.

 

If the sequence has some star channels, copy and paste them in a similar manner.

 

Things To Note

 

The Demo version

Default Layout

PowerPoint Presentations

 

The Demo Version

 

The Demo version of the SuperStar Sequencer will not export sequences.  However, all other functionality is the same as the paid verisons.   You can sequence to any number of ribbons and save the sequence in the SuperStar format; you just can't export those SuperStar sequences to the Sequence Editor.

 

Default Layout

 

The default layout is 12 Cosmic Color Ribbons (CCRs) with a star at the top.  The star is optional, and the number of ribbons is configurable from 1 to 64.  To change the configuration, click on the Tools menu and select "Configuration".

 

PowerPoint Presentations

 

There are PowerPoint presentations related to SuperStar which you can download from the Light-O-Rama website.