The Standard Toolbar

Top  Previous  Next

The Light-O-Rama Sequence Editor's Standard toolbar contains buttons for several functions and options.  From left to right, they are:

 

StandardToolbarNew New Sequence

StandardToolbarOpen Open Sequence

StandardToolbarClose Close Sequence

StandardToolbarSave Save Sequence

StandardToolbarCut Cut

StandardToolbarCopy Copy

StandardToolbarPaste Paste

StandardToolbarRepeat Repeat

StandardToolbarUndo Undo

StandardToolbarRedo Redo

StandardToolbarViewAnimation View Animation

StandardToolbarViewFadesAsRamps View Fades as Ramps

StandardToolbarViewChannelButtons View Channel Buttons

StandardToolbarVaryChannelButtonColors Vary Channel Button Colors

StandardToolbarViewTimeScale View Time Scale

StandardToolbarViewWaveform View Waveform

StandardToolbarZoomChannelsOut Zoom Channels Out

StandardToolbarZoomChannelsIn Zoom Channels In

StandardToolbarZoomTimeOut Zoom Time Out

StandardToolbarZoomTimeIn Zoom Time In

StandardToolbarPlay Play

StandardToolbarPlayAgain Play Again

StandardToolbarStop Stop

StandardToolbarLightsOffNow Lights Off Now

 

If desired, the toolbar can be hidden (or unhidden) via "Tool Bars" on the View menu.

 

StandardToolbar

The Standard toolbar

 

New Sequence StandardToolbarNew

 

This button on the Standard toolbar can be used to create a new sequence.  Clicking on it opens the New and Open dialog, on its "New Sequence" tab.

 

Open Sequence StandardToolbarOpen

 

This button on the Standard toolbar can be used to open a sequence.  Clicking on it opens the New and Open dialog, on whichever of its "Existing Sequence" tab or its "Recent Sequence" tab was most recently used.

 

Close Sequence StandardToolbarClose

 

This button on the Standard toolbar can be used to close an open sequence.  Please see "Close" on the File menu for details.

 

Save Sequence StandardToolbarSave

 

This button on the Standard toolbar can be used to save changes to an open sequence.  Please see "Save" on the File menu for details.

 

Cut StandardToolbarCut

 

This button on the Standard toolbar can be used to cut effects from a sequence.  Please see "Cut, Copy, Paste, and Paste Multiple" on the Edit menu for details.

 

Copy StandardToolbarCopy

 

This button on the Standard toolbar can be used to copy effects from a sequence.  Please see "Cut, Copy, Paste, and Paste Multiple" on the Edit menu for details.

 

Paste StandardToolbarPaste

 

This button on the Standard toolbar can be used to paste effects into a sequence.  Please see "Cut, Copy, Paste, and Paste Multiple" on the Edit menu for details.

 

Repeat StandardToolbarRepeat

 

The Repeat tool can be used to automatically place a copy of the selected area immediately after the selected area.  For example, consider the following:

 

Repeat0

Before repeating

 

Then pressing the Repeat button will make the following:

 

Repeat1

After repeating once

 

And you can repeat as many times as you like thereafter; for example, pressing Repeat three more times will make the following:

 

Repeat4

After repeating four times

 

The Repeat tool pays attention to your current "Paste from Foreground" setting.  For example, before repeating:

 

RepeatFromForeground0

Before repeating

 

And after repeating, with "Paste from Foreground" enabled:

 

RepeatFromForeground1

After repeating, with "Paste from Foreground" enabled

 

Undo StandardToolbarUndo

 

This button on the Standard toolbar can be used to undo changes to a sequence.  Please see "Undo and Redo" on the Edit menu for details.

 

Redo StandardToolbarRedo

 

This button on the Standard toolbar can be used to redo previously undone changes to a sequence.  Please see "Undo and Redo" on the Edit menu for details.

 

View Animation StandardToolbarViewAnimation

 

This button on the Standard toolbar can be used to control whether the animation for a sequence is displayed.  This can be set independently for different open sequences.  Please see "View Animation" on the View menu for details.

 

View Fades as Ramps StandardToolbarViewFadesAsRamps

 

This button on the Standard toolbar can be used to control whether fades are displayed as gradual changes in color or as ramps.  Please see "Fades" on the View menu for details.

 

View Channel Buttons StandardToolbarViewChannelButtons

 

This button on the Standard toolbar can be used to control whether the channel buttons for a sequence are displayed.  This can be set independently for different open sequences.  Please see "View Channel Buttons" on the View menu for details.

 

Vary Channel Button Colors StandardToolbarVaryChannelButtonColors

 

This button on the Standard toolbar can be used to control whether the channel buttons for a sequence will change color during play, based upon the lighting effects happening on those channels.  Please see "Vary Color of Channel Buttons" on the Play menu for details.

 

View Time Scale StandardToolbarViewTimeScale

 

This button on the Standard toolbar can be used to control whether a time scale is displayed at the top of an open sequence.  This can be set independently for different open sequences.  Please see "View Time Scale" on the View menu for details.

 

View Waveform StandardToolbarViewWaveform

 

This button on the Standard toolbar can be used to control whether the audio waveform is displayed at the top of an open musical sequence.  This can be set independently for different open musical sequences.  Please see "View Waveform" on the View menu for details.

 

Zoom Channels Out StandardToolbarZoomChannelsOut

 

This button on the Standard toolbar can be used to zoom a sequence's rows (representing its channels) out, making them shorter.  Please see "Zoom Rows" on the View menu for details.

 

Zoom Channels In StandardToolbarZoomChannelsIn

 

This button on the Standard toolbar can be used to zoom a sequence's rows (representing its channels) in, making them taller.  Please see "Zoom Rows" on the View menu for details.

 

Zoom Time Out StandardToolbarZoomTimeOut

 

This button on the Standard toolbar can be used to zoom a sequence's columns (representing the duration from one timing to the next) out, making them thinner.  Please see "Zoom Columns" on the View menu for details.

 

Zoom Time In StandardToolbarZoomTimeIn

 

This button on the Standard toolbar can be used to zoom a sequence's columns (representing the duration from one timing to the next) in, making them wider.  Please see "Zoom Columns" on the View menu for details.

 

Play StandardToolbarPlay

 

This button on the Standard toolbar can be used to start play of an open sequence or sequences.  If only a single sequence is open, it will be played; if more than one sequence is open, a popup menu will open, asking if you want to play all of the sequences or just the currently active sequence.  Please see "Start This Sequence" and "Start All Sequences" on the Play menu for details.

 

Play Again StandardToolbarPlayAgain

 

This button on the Standard toolbar can be used to start play in the same way as it was last started.  Please see "Play Again" on the Play menu for details.

 

Stop StandardToolbarStop

 

This button on the Standard toolbar can be used to stop a playing sequence.  Please see "Stop" on the Play menu for details.

 

Lights Off Now StandardToolbarLightsOffNow

 

This button on the Standard toolbar can be used to manually turn off lights.  Please see "Lights Off Now" on the Play menu for details.