The New Musical Sequence Dialog

Top  Previous  Next

The Sequence Editor's New Musical Sequence dialog is used to create a new musical sequence.  The New Musical Sequence dialog is opened by selecting "New Musical Sequence" from the New and Open dialog's "New Sequence" tab.  The New and Open dialog, in turn, can be opened in a few ways:

 

Selecting "New" from the File menu;
Clicking the "New Sequence" button on the Standard toolbar;
Using the keyboard shortcut Ctrl-N.

 

After doing one of these things, but before the New Musical Sequence dialog opens, you will be prompted to select the audio or video file that you want to build the new sequence based off of.  After you select such a file, then the New Musical Sequence dialog will open.

 

For detailed help, please refer to the following sections:

 

Author of this new sequence
Musical Information
Channel Setup
Initial Timing
Save as defaults.
Don't ask me this again.

 

NewMusicalSequence

The New Musical Sequence dialog

 

Author of this new sequence

 

If you wish, you can put your name here.  It will be saved with the sequence, and will be displayed as a part of the information available via "Sequence Info" of the View menu.

 

Once set, even if set to a blank value, this cannot be changed.

 

Musical Information

 

If you wish, you can put the name of the artist, song, and album of the associated song here.  It will be saved with the sequence, and will be displayed as a part of the information available via "Sequence Info" of the View menu.

 

If you are basing the sequence on an MP3 file, and the file is tagged with this information, it will automatically be placed into this section (though you can still change or delete it if you wish).

 

You can change this information later, via "Sequence Info" of the Edit menu.

 

Channel Setup

 

In this section, you can either specify the number of channels that you want in this sequence, or specify that the channels should be set up based upon a channel configuration file.

 

If you specify the number of channels, you can also check the "Using standard LOR controllers" checkbox, which will cause the channels in the new sequence to be automatically set up to use Light-O-Rama controllers.  The first channel will be set up to use unit 1 circuit 1, the next unit 1 circuit 2, and so forth, up through unit 1 circuit 16, and then on to unit 2, and so forth.  All such channels will be set up to use the regular LOR network.

 

Unless you use a channel configuration file, all channels specified here will be placed into a single track.  More tracks can be added later, for example via Add New Track or Duplicate Track of the Edit menu.

 

You can always change the number of channels or their settings later, by adding or removing channels, for example via the Channel Configuration screen or via a channel's right-click popup menu.

 

Initial Timing

 

This allows you to tell the Sequence Editor to automatically insert timings into the new sequence.  Timings are the spots in time where you can easily place lighting effects - for example, turn a string of lights on, or have it twinkle, or have it fade down.

 

In addition to placing timings a certain length of time apart (a tenth of a second, a half second, a second, or "some other value"), add adding no timings at all ("Don't add any timings"), you can instruct the Sequence Editor to use various wizards to insert timings based upon the song itself:

 

The MIDI Wizard can insert timings and effects based upon the beat of a MIDI song, as well as based on the individual notes played by different instruments in the song.
The Tapper Wizard allows you to tap the keyboard or mouse while the song plays, and will record the times at which you tap.
The Beat Wizard attempts to determine the tempo of the song, and insert timings and effects based upon it.
The VU Wizard looks for peaks in the song, much like a VU meter, and inserts timings and effects based upon them.

 

Not all of these wizards are available for every type of media file; for example, the MIDI Wizard can only be used with MIDI files.  Any wizards that cannot be used with the type of media file being used will be greyed out.

 

If you select "Some other value", you can enter any length you want, rather than one of the defaults.  For details on the format used to specify various lengths of time, please see Time Format.

 

If you choose to have equally spaced timings, then you will be given the option to use a fixed timing grid or  a freeform timing grid, by checking or unchecking the "Use a fixed timing grid" box.  Otherwise, a freeform timing grid will be used.

 

Note that you can always insert, delete or move timings later, in a variety of ways.

 

Save as defaults.

 

If you turn this checkbox on, your answers to most of the questions in this dialog will be saved so that whenever you create a new musical sequence in the future, those answers will automatically show up in this dialog as the default answers.

 

The Musical Information section - i.e. the artist name, album name, and song name - will not be saved as defaults (though if you use an MP3 tagged with this information, it will automatically be placed into that section).

 

Don't ask me this again.

 

If you turn this checkbox on, then whenever you create new musical sequences in the future, you will not be presented with this dialog.  Instead, the default answers to the questions will be used.

 

If you later decide that you want to change these defaults, you can do so by going to the New Musical Sequence Preferences dialog, from Preferences submenu of the Edit menu.