Export

Top  Previous  Next

If you are running the Demo version of the Light-O-Rama SuperStar Sequencer, then Export will not work, but you may want to read through this section just to see how it works in the full version.

 

The SuperStar Sequencer stores the effects in ".sup" files, but the effects can be exported as ".lms" or ".las" files so that the Light-O-Rama Sequence Editor can read and play them.

 

Initialize the screen
Launch the Scene dialog box
Create a scene using the first pixel of the first ribbon
Save as an .sup file
Export as an animation sequence
Open the animation sequence with the Sequence Editor
Load the file as a subsequence in the Sequence Editor
Discussion

 

Initialize the screen

 

Click on the toolbar button with a piece of paper on it.  This will do three things: It will clear the pixel grid, set the start color as red, and set the time duration to 1.00-2.00 seconds.

 

Launch the Scene dialog box

 

Click on the Tools menu and select "Scenes".  The Scene dialog box will launch.

 

Create a scene using the first pixel of the first ribbon

 

Click on the upper left pixel of the pixel grid, then click on the "Add" button in the Scene dialog box.

 

Save as an .sup file

 

Click on the File menu, then click on "Save As".  In the Save As dialog box, type "OnePixel".  Click on the Save button, and the effect will be saved as OnePixel.sup.

 

Export as an animation sequence

 

Click on the File menu, and then click on Export.  If you are running the Demo version, you will get an error box saying that Export is not available, but if you are running the full version, the "Save as Light-O-Rama Animation Sequence" dialog box will appear.  The name of the file will default to "OnePixel.sup.las"; click on the Save button, and the file will be saved in the Light-O-Rama Sequences directory.

 

Open the animation sequence with the Sequence Editor

 

Launch the Light-O-Rama Sequence Editor and open the file "OnePixel.sup.las".  On the left side, the first 16 channel buttons will be labelled "Star 01" through "Star 16".  The 17th button will be labelled "CCR01-P01-Red", and on this row there will be a fade from 1.00 to 2.00 seconds.  Note that "CCR01" means "Ribbon 1", and "P01" means "Pixel 1".

 

Also note that with a star and 12 ribbons there are 1936 channels in the Sequence Editor.  Imagine trying to sequence 12 ribbons using this huge grid! The SuperStar Sequencer makes it so that you do not have to deal with this grid.

 

Load the file as a subsequence in the Sequence Editor

 

Close the "OnePixel.sup.las" file in the Sequence Editor.
Open any existing animation sequence or musical sequence that you already have.
Right click on the first channel button at the top of your sequence.
In the popup menu, select "Insert Channel Above".
Right click on the "New Channel" button that you just inserted.
In the popup menu, select "Change Channel Settings";  the Channel Settings dialog box will appear.
Change the name of the channel to something like "SuperStar".
In the "Device Type"dropdown list, select "Sequence".
On the "Sequence" line (near the bottom of the dialog), click on the "..." button.  The "Open" dialog box will appear.
Select the file "OnePixel.sup.las", and click on the "Open" button.
Click on the "OK" button in the Channel Settings dialog box.

 

You are not done yet! The subsequence will only be played while the grid boxes for this channel are on.  So, you want to set the grid boxes on for the entire row, all the way to the end of the sequence.  To do this:

 

Select one of the boxes on the row.  Click on the Edit menu, hover over Select, and a flyout menu will appear.  On the flyout menu click on "Row(s)".  This will select the entire row.
Right click  on one of the boxes in th the row, and select "On" from the popup menu.  This will turn the entire row on.

 

Now when you play your sequence, the subsequence will be played at the same time.

 

The main sequence and the subsequence should not both try to control the same lights; it is recommended that any circuits referred to in the subsequence are removed from and kept out of the main sequence.  Doing otherwise may cause unpredictable results.

 

Discussion

 

The file extension ".lms" stands for "Light-O-Rama Musical Sequence", and ".las" stands for "Light-O-Rama Animation Sequence".  The file in the exercise was saved as an animation sequence because there was no music file loaded.  If you opened a song file for "OnePixel.sup, it would have been exported as a musical sequence ("OnePixel.sup.lms") instead of an animation sequence ("OnePixel.sup.las").

 

In the exercise, we used the default name of "OnePixel.sup.las".  However, you could name it anything you want, so long as it ends with ".las" or ".lms".  For example, you could call it "OnePixel.lms" or "FromSuperStar.lms".  But the idea is that if you already have a musical sequence for your other lights, called "MyAwesomeSequence.lms", and you want to incorporate your Cosmic Color Ribbons as a part of that same show, then in the SuperStar Sequencer you could call it "MyAwesomeSequence.sup", and when it gets exported it will be called "MyAwesomeSequence.sup.lms".  Thus it would be clear that it is an .lms file exported from an .sup file.

 

It is expected that MyAwesomeSequence.lms and MyAwesomeSequence.sup.lms both use the same music file and both are of the same length.  However, if MyAwesomeSequence.sup.lms were shorter than the main sequence, and the channel assigned to the subsequence were on for the entire length of the main sequence, then the subsequence will loop and start playing over.