Display Preferences

Top  Previous  Next

The Sequence Editor's Display Preferences dialog (which can be opened from the Preferences submenu of the Edit menu) gives control over some aspects of how the Sequence Editor looks:

 

General Preferences
View Channel Buttons by Default
View Fades as Ramps by Default
View Time Scale by Default
View Wave Form by Default
Tooltip Preferences
Enable tooltips
Seconds before opening
Use Channel Colors
Seconds before closing automatically
Manually close tooltips on mouseover
Manually close tooltips on click
Animation Redraw Throttling
Advanced OpenGL Settings

 

DisplayPreferences

The Display Preferences dialog

 

General Preferences

 

View Channel Buttons by Default
View Fades as Ramps by Default
View Time Scale by Default
View Wave Form by Default

 

View Channel Buttons by Default

 

If this box is checked, the channel buttons for each channel in a sequence will be displayed whenever a sequence is created or opened.

 

If you don't want to change this default, but want to temporarily change whether or not channel buttons are displayed, you can use "Channel Buttons" from the View menu, or "View Channel buttons" from the Standard toolbar, or click on the thick grey vertical bar to the left of the sequence's grid (and, if channel buttons are currently visible, to the right of them).

 

DisplayPreferencesBaseline

A sequence with channel buttons displayed

 

DisplayPreferencesNoChannelButtons

The same sequence, with channel buttons hidden

 

View Fades as Ramps by Default

 

If this box is checked, fades and intensities will be displayed as ramps by default, whenever a sequence is opened or created.  This means that a cell with a fade or an intensity will be displayed as partially filled in, based upon how bright the fade or intensity is, rather than as shades of the channel's color.

 

If you don't want to change this default, but want to temporarily change whether fades are displayed as ramps or as colors, you can use the Fades submenu of the View menu, or "View Fades as Ramps" from the Standard toolbar.

 

DisplayPreferencesBaseline

A sequence, with fades displayed using colors

 

DisplayPreferencesFadesAsRamps

The same sequence, with fades displayed as ramps

 

View Time Scale by Default

 

If this box is checked, then whenever a sequence is created or opened, a time scale will be displayed at the top of the sequence.

 

If you don't want to change this default, but want to temporarily change whether a time scale is displayed or not, you can use "Time Scale" from the View menu, or "View Time Scale" from the Standard toolbar.

 

DisplayPreferencesBaseline

A sequence, with a time scale displayed

 

DisplayPreferencesNoTimeScale

The same sequence, with no time scale displayed

 

View Wave Form by Default

 

If this box is checked, then whenever a musical sequence is created or opened, a wave form of the song will be displayed near the top of the sequence (except for sequences using certain types of media files, such as MIDI files and video files).  This setting has no effect on the display of musical sequences using those types of media files, or of animation sequences.

 

If you do not want to change this default, but want to temporarily change whether wave form is displayed or not, you can use "Wave Form" from the View menu, or "View Wave Form" from the Standard toolbar.

 

DisplayPreferencesBaseline

A sequence, with a waveform displayed

 

DisplayPreferencesNoWaveForm

The same sequence, with no waveform displayed

 

Tooltip Preferences

 

Enable tooltips
Seconds before opening
Seconds before closing automatically
Manually close tooltips on mouseover
Manually close tooltips on click

 

Enable tooltips

 

If this box is checked, when the mouse is over a sequence grid, a tooltip displaying information about the cell being pointed to can be displayed.  You can control more specific behaviors of the tooltip via other tooltip preferences.

 

Seconds before opening

 

If tooltips are enabled, this text box controls how many seconds it will take before the tooltip pops up, when the mouse is kept still over a sequence grid.

 

You do not have to specify a whole number; for example, you can set it to three-quarters of a second by entering "0.75".

 

Use Channel Colors

 

If tooltips are enabled, this checkbox controls whether or not tooltips associated with channels will display the color of the channel.

 

Seconds before closing automatically

 

If tooltips are enabled, this checkbox and text box control whether or not they will automatically close themselves a certain amount of time after being opened.  If the checkbox is checked, they will automatically close after the number of seconds specified in the text box.

 

You do not have to specify a whole number; for example, you can set it to three-quarters of a second by entering "0.75".

 

Manually close tooltips on mouseover

 

If tooltips are enabled, selecting this option will make them close when you roll your mouse over them.  The other option is to make them close when you click on them.

 

Manually close tooltips on click

 

If tooltips are enabled, selecting this option will make them close when you click on them.  The other option is to make them close when you roll your mouse over them.

 

Animation Redraw Throttling

 

During play, the Animator will only redraw the animation every so often, suppressing more frequent redraw requests.  This is done to try to ensure that it does not take up too much of the computer's CPU time.  However, it means that very fast events may not get displayed by the Animator (although they will still affect your actual lights).

 

The amount of throttling that the Animator will do is configurable.  By default, it is set to "Low", which means that it doesn't throttle very much, and therefore the animation should be as smooth as possible.  The cost of this smoothness is that the Animator will use more of your computer's CPU time.

 

So, if you notice that the Animator is having a hard time keeping up with your sequence, making the animation and perhaps even the sequence itself choppy or sluggish, it may be because the Animator is using too much CPU time for your computer.  In this case, you may want to try changing this setting to "Medium", which will cause the Animator to allow redrawings less frequently, thereby decreasing the amount of CPU time it uses.  "High" will decrease CPU utilization even further.

 

Advanced OpenGL Settings

 

This button opens up the Advanced OpenGL Settings dialog, which can be used experimentally to try to resolve various strange graphics issues.  However, this is not recommended, and often other steps (such as updating your graphics card's driver) will resolve graphics issues in a better manner.